[OPEN-ILS-DEV] Evergreen installation problems

Keith Kelley keith.kelley at wmich.edu
Fri Feb 15 13:47:50 EST 2008

Thanks Dan. apt-get install postgresql-plperl-8.1 got me a bit
farther, until this:

wlib-210:/usr/bin# su -c "psql -f
/usr/share/postgresql/8.1/contrib/tablefunc.sql evergreen" -
/usr/share/postgresql/8.1/contrib/tablefunc.sql: No such file or
>>> Dan Scott <denials at gmail.com> 02/15/08 1:36 PM >>> 
On 15/02/2008, Keith Kelley <keith.kelley at wmich.edu> wrote:
>  Hi John,
>  I installed a Debian box and it is quite a bit easier to get
>  farther than with a Fedora Core box. I followed the directions
>  All went reasonably well until I got to:
>  su -c "createlang plperl evergreen" - postgres
>  which responded with:
>  createlang: language installation failed: ERROR:  could not
>  file "$libdir/plperl": No such file or directory
>  Now, the first time I tried, I'd installed from the DVD with
>  database server and webserver options, and I noticed it
>  with postgres 7.4, so I wiped it out and tried again without
>  options, but it still put the 7.4 clients on the system.
>  apt-get remove postgresql-client didn't remove the 7.4 clients
>  apt-get install postgresql-8.1 did replace the 7.4 binaries
>  8.1
>  But now that this is my second install of 40r2 and I'm still
>  getting the same error I decided to stop there and ask for your
>  wisdom on the matter.

Hmm. If you ran into dependency problems with the install script,
it probably blocked the install of a number of other postgresql
packages, like postgresql-plperl-8.1

I wonder if there's an explicit install target that Bill and I
people would choose (like "dev-server") in the Debian install
that is resulting in this sort of problem.

We could update the Makefile.install to include these dependencies
include an explicit -8.1 suffix.

Dan Scott
Laurentian University

More information about the Open-ils-dev mailing list